Контакты
изменить дизайн
Искать!
Настройка сети
Для абонента сети

Настройка Cisco 800 Series

Базовая настройка

Дан роутер с заводскими настройками.

Войти в режим конфигурации
configure terminal

Поставить пароль на роутер
username <ваш логин на роутер, например, admin> privilege 15 password <ваш пароль для роутера>

Изменить имя роутера
hostname <имя роутера home-router>

По умолчанию, с нулевого по третий порты FastEthernet(на корпусе помечены как LAN) объединены в Vlan 1
Vlan 1 имеет IP адрес 10.10.10.1 с маской 255.255.255.240
Это означает, что в Vlan 1 данный роутер сможет обслуживать адреса с 10.10.10.0 по 10.10.0.15, причем 10.10.10.0 - адрес сети, 10.10.10.15 - broadcast.
10.10.10.1 - занят под шлюз. Остается 13 адресов.

Можно расширить диапазон, чтобы подключить более 13 компьютеров к данному роутеру.
Например, для всех уже привычные 255 адресов (10.10.10.0 - адрес сети, 10.10.10.255 - broadcast)
interface Vlan1
ip address 10.10.10.1 255.255.255.0

На Cisco 800 Series по умолчанию включен сервер DHCP
В DHCP тоже нужно расширить диапазон выдаваемых адресов и добавить сетевые настройки fryazino.net
ip dhcp pool ccp-pool
no network 10.10.10.0 255.255.255.240
network 10.10.10.0 255.255.255.0
dns-server 192.168.2.20 192.168.2.90
domain-name fryazino.net

Заметить, что для ограничения доступа к Cisco на line vty 0 4 присутствует access-class 23 in
Расширить в access-list 23 диапазон адресов с которых возможен доступ

В access-list необходимо использовать инвертированную маску
Для 255.255.255.240 -- это 0.0.0.15
Для 255.255.255.0 -- это 0.0.0.255
no access-list 23 permit 10.10.10.0 0.0.0.15
access-list 23 permit 10.10.10.0 0.0.0.255

Отключить http, https серверы
no ip http server
no ip http secure-server

Для доступа к сети нужно настроить на четвертом порту FastEthernet(на корпусе помечено как WAN) IP-адрес, который прописан в приложении к договору fryazino.net
interface FastEthernet4
ip address <ваш адрес 192.168.xxx.xxx> <ваша маска подсети 255.255.255.xxx>

Настроить маршрутизацию для локальной сети
ip route 192.168.0.0 255.255.0.0 <адрес шлюза 192.168.xxx.1>

Настройка L2TP

Описать класс pseudowire. Имя l2tp-internet. Инкапсуляция l2tp версии 2. Соединение с интерфейса FastEthernet4 (WAN).
pseudowire-class l2tp-internet
encapsulation l2tpv2
ip local interface FastEthernet4

Описать виртуальный интерфейс PPP. Отключить Cisco Discovery Protocol. Получить IP-адрес автоматически. Логин. Пароль. Адрес VPN-сервера. VC ID. Имя pseudowire класса. В данном случае VC ID = 1.
interface Virtual-PPP1
no cdp enable
ip address negotiated
ppp chap hostname <ваш логин для доступа в Интернет>
ppp chap password <ваш пароль для доступа в Интернет>
pseudowire <адрес сервера VPN, например, 192.168.2.9> 1 pw-class l2tp-internet

Настроить маршрутизацию для Интернета
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

Настройка NAT

Описать направления трафика с помощью access-list -- в сеть Фрязино(FryazinoNet) и в Интернет(Internet)
Сеть Фрязино имеет адреса 192.168.0.0/255.255.0.0
Все, что не входит в сеть Фрязино считается Интернетом
В access-list необходимо использовать инвертированную маску
Для 255.255.255.0 -- это 0.0.0.255
Для 255.255.0.0 -- это 0.0.255.255
ip access-list extended FryazinoNet
permit ip 10.10.10.0 0.0.0.255 192.168.0.0 0.0.255.255


ip access-list extended Internet
deny ip 10.10.0.0 0.0.0.255 192.168.0.0 0.0.255.255
deny ip 10.10.0.0 0.0.0.255 host 255.255.255.255
permit ip 10.10.0.0 0.0.0.255 any

Для внешних интерфейсов установить ip nat outside. Для внутренних интерфейсов -- ip nat inside.
interface Virtual-PPP1
ip nat outside

interface FastEthernet4
ip nat outside

interface Vlan1
ip nat inside

Создать правила NAT для Фрязинской сети и для сети Интернет
ip nat inside source list FryazinoNet interface FastEthernet4 overload
ip nat inside source list Internet interface Virtual-PPP1 overload

Выйти из режима конфигурации
end

Сохранить конфигурацию
copy running-config startup-config

fryazino.net (ООО "Фрязинский городской информационный центр") © 2006